YUM thread.error: can’t start new thread

При попытке обновить VDS на CentOS с помощью команды yum update возникает следующая ошибка:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
File «/usr/bin/yum», line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File «/usr/share/yum-cli/yummain.py», line 229, in user_main
errcode = main(args)
File «/usr/share/yum-cli/yummain.py», line 104, in main
result, resultmsgs = base.doCommands()
File «/usr/share/yum-cli/cli.py», line 339, in doCommands
self._getTs(needTsRemove)
File «/usr/lib/python2.4/site-packages/yum/depsolve.py», line 101, in _getTs
self._getTsInfo(remove_only)
File «/usr/lib/python2.4/site-packages/yum/depsolve.py», line 112, in _getTsInfo
pkgSack = self.pkgSack
File «/usr/lib/python2.4/site-packages/yum/__init__.py», line 591, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File «/usr/lib/python2.4/site-packages/yum/__init__.py», line 434, in _getSacks
self.repos.populateSack(which=repos)
File «/usr/lib/python2.4/site-packages/yum/repos.py», line 223, in populateSack
self.doSetup()
File «/usr/lib/python2.4/site-packages/yum/repos.py», line 71, in doSetup
self.ayum.plugins.run(‘postreposetup’)
File «/usr/lib/python2.4/site-packages/yum/plugins.py», line 176, in run
func(conduitcls(self, self.base, conf, **kwargs))
File «/usr/lib/yum-plugins/fastestmirror.py», line 181, in postreposetup_hook
all_urls = FastestMirror(all_urls).get_mirrorlist()
File «/usr/lib/yum-plugins/fastestmirror.py», line 333, in get_mirrorlist
self._poll_mirrors()
File «/usr/lib/yum-plugins/fastestmirror.py», line 376, in _poll_mirrors
pollThread.start()
File «/usr/lib/python2.4/threading.py», line 416, in start
_start_new_thread(self.__bootstrap, ())
thread.error: can’t start new thread

Обычно это возникает по причине того, что не хватает памяти для плагина fastestmirror.

Есть два варианта решения проблемы:

  1. Если у вас на сервере запущен MySQL — отключите его.
  2. Отключите использование этого плагина следующей командой:

yum —disableplugin=fastestmirror update

Другие публикации по теме:

Установка Apache-ITK для Centos 5.5 Добавьте в систему дополнительный сторонний репозитарий командой:rpm -ihv http://centos.alt.ru/repository/centos/5/i386/centalt-release-5-3.noa...
Обновление phpMyAdmin, проблемы с безопасностью... Уже практически неделю буйствует эпидемия среди серверов на базе Linux, вызванная проблемой с безопасностью в phpMyAdmin, о которой можно прочесть в р...
Установка php 5.2 на CentOS 6 Только никому не говорите, что я это вам рассказал.До сих пор остались сайты, которым для работы требуется php 5.2.x, на CloudLinux эту проблему р...
Поиски современного браузера, firefox 3.6.7 никуда... Нахожусь в немного шокированном состоянии - в официальных репозиториях Fedora 13 находится старая версия Firefox и никто не чешется обновлять (Не забы...

Поделиться информацией с друзьями!

Чтобы не пропустить обновления, подпишись на RSS или почтовую рассылку (свой выбор сделали уже 128 человек!)

1 комментарий к “YUM thread.error: can’t start new thread

  1. Просто дикое количество спама идет исключительно на эту страницу. Даже и не знаю, чего придумать. Сейчас даже какой-то адекватный спам и на комментарии похож =)

Оставить комментарий