Стабильное обновление Manjaro Linux 2016-09-20 — Linux 4.8, KDE Framework 5.26, Gambas3, Mesa, Octopi

На этой неделе сообществу Manjaro Linux был представлен очередной пакет обновлений. В него включили KDE Framework 5.26. Ядро Linux 4.8 будет представлено в шестом релиз-кандидате. Php, haskel и gamba3 обновлены до их последних версий и проведена работа с другими приложениями. Дополнительно были исправлены некоторые ошибки в Octopi и Pamac, а так же обновлён пакет приложений manjaro-tools до 0.13.x.

Остальная пакетная база синхронизирована с Archlinux на состояние от Tue Sep 20 07:22 CEST 2016.

Ниже представлены известные проблемы и их решения.


Информация для пользователей Catalyst

Если вы используете видеокарту AMD с Catalyst, НАСТОЯТЕЛЬНО РЕКОМЕНДУЕТСЯ использовать для обновления pacman!!! Как теперь нужно работать с Catalyst:

  • Catalyst-Utils требует три новых пакета: catalyst-video, catalyst-input и catalyst-server.
  • Catalist-Video предоставляет несколько нужных драйверов типа Intel и Vesa для тех, кто использует гибридные системы (интегрированная и дискретная видеокарта)
  • Catalyst-Input содержит нужные драйвера для ввода
  • Catalyst-Server предоставляет совместимость с Xorg-Server

Без этих пакетов корректная работа Catalyst гарантироваться не будет.

 

Отключение генерации случайного MAC-адреса для WLAN

С помощью nmcli установите значение для 802-11-wireless.mac-address-randomization на never для каждого соединения или добавьте блок параметров

[device]
wifi.scan-rand-mac-address=no

в файл /etc/NetworkManager/NetworkManager.conf для полного отключения этой функции.

 

Проблемы с обновлением MATE

При использовании mate-menu, установленного из AUR, в случае использования GTK2-версии MATE, удалите этот пакет перед обновлением.

 

LibreOffice и GTK3

LibreOffice может поломаться в оконном окружении, основанный на GTK. Но все можно привести в порядок, отредактировав файл  /etc/profile.d/libreoffice*sh. Рекомендуется раскомментировать строку SAL_USE_VCLPLUGIN=gtk. Редакция Manjaro с KDE не поддвержено такой ошибке.

 

GTK3

Мы обновили Gnome и GTK до версии 3.20. Это может поломать много тем оформления, которые потом будут исправлены, если их разработчики выпустят обновление. Некоторые темы уже отвечают требованиям GTK 3.20 и проблем с ними не будет. Если проблемы все же возникли, читаем дальше.

Новая тема Manjaro по умолчанию — Vertex-Maia. Она полностью совместима с GTK 3.20

Чтобы установить её выполните команду:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

Пользователи KDE так же могут установить эту тему таким образом:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

 

Приложения на Qt совместно с GTK — может быть полезно для не-KDE оконных!

При использовании Qt 5.7 нужно установить qt5-styleplugins и qt5ct, а так же настроить вашу систему, чтобы снова выглядела хорошо

 

ufw

Если возникли проблемы с ufw (к примеру, не работает), скопируйте ваши персональные правила в другую директорию. К примеру так:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

 

steam

Steam может перестать работать из-за несовместимости с библиотекой libgpg. Для «исправления» выполните следующие команды:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

 

  • Источник: https://forum.manjaro.org/t/stable-update-2016-09-20-linux-4-8-kde-framework-5-26-gambas3-mesa-octopi/9692

Другие публикации по теме:

Доступен 11 пакет обновлений для Manjaro Linux... Это последний пакет обновлений для среза Manjaro 0.8.10. Он включает в себя обновления для многих ядер. Были убраны пакеты linux38 и linux31, и если ...
От привычки не избавиться ;-) screen vs tmux... На протяжении долгих лет пользовался screen и как-то недоверчиво посматривал на клонов типа tmux. Но все же последняя новость о новом релизе tmux и оп...
Помощь в локализации нового графического установщи... Начиная с Manjaro 0.9.0, установка будет производиться с помощью нового графического инсталлятора, который получил название Calamares. Разработчики в ...
Доступен 12 пакет обновлений для Manjaro Linux... Несмотря на то, что разработчики дистрибутива Manjaro Linux ранее сообщили, что 11-е обновление будет последним, вчера они обнародовали новый пакет. ...

Поделиться информацией с друзьями!

Чтобы не пропустить обновления, подпишись на RSS или почтовую рассылку (свой выбор сделали уже 128 человек!)

Оставить комментарий