yandex

Скрипт для понижения версии php с 5.4 до 5.3

На просторах зарубежных убунтоводских форумов был найден скрипт, который позволяет понижать версию php до 5.3 на Ubuntu.

При некоторых изменениях, думаю, он может подойти и для Debian.

Скачиваем скрипт (он прикреплен ниже). Указываем исполняющие права командой:

chmod +x ./php5_4_downgrade_5.3.sh

После чего запускаем. Обращаю внимание, что запуск должен производится из-под root или с использованием sudo

sudo ./php5_4_downgrade_5.3.sh

и следуем инструкции, выводимой на экран. Надеюсь, там не должно возникнуть никаких сложностей. Нет возможности/желания проверить как оно работает =). Пробежался глазами по скрипту, вроде как делает то, для чего предназначен =) никакого rm -rf /* нет =))

 

PS: для Ubuntu 12.10

  • Источник: http://ubuntuforums.org/showthread.php?t=2074178

комментария 2

  1. Вит:

    Скрипт отработал без проблем. Убунта 12.10. Спасибо!

  2. Дмитрий:

    НЕДЕЛЮ ВОЗИЛСЯ с запуском двух версий php на сайте. В поисковике попал на этот сайт, скачал, установил, ВСЕ РАБОТАЕТ! СПАСИБО!

Добавить комментарий

Ваш адрес email не будет опубликован.